More information about the Underscore mailing list

[_] Etch to Lenny problems

Martin Moore martin.moore at avbrief.com
Fri Jul 9 14:11:37 BST 2010

dpkg -S Find.pm
perl-modules: /usr/share/perl/5.10.0/Pod/Find.pm
libmodule-find-perl: /usr/share/perl5/Module/Find.pm
perl-modules: /usr/share/perl/5.10.0/File/Find.pm

So does this mean @INC needs changing?

If so, what/where/how!


Ta.
 

-----Original Message-----
From: Martin Moore [mailto:martin.moore at avbrief.com] 
Sent: 09 July 2010 12:54
To: underscore at under-score.org.uk
Subject: Re: [_] Etch to Lenny problems

 # perl -MFile::Find
Can't locate File/Find.pm in @INC (@INC contains: /usr/share/perl5/
/usr/share/perl/5.8.4 /etc/perl /usr/local/lib/perl/5.8.8
/usr/local/share/perl/5.8.8 /usr/lib/perl5 /usr/share/perl5
/usr/lib/perl/5.8 /usr/share/perl/5.8 /usr/local/lib/site_perl
/usr/local/lib/perl/5.8.4 /usr/local/share/perl/5.8.4 .).
BEGIN failed--compilation aborted. 

-----Original Message-----
From: Andrew McGregor [mailto:andy at txm.net]
Sent: 09 July 2010 12:35
To: underscore at under-score.org.uk
Subject: Re: [_] Etch to Lenny problems

File::Find is a built in, if so it won't be the first time the Debian
maintainers have screwed up the Perl installation which is vital for package
management :(

What happens when you run:

 perl -MFile::Find



On 9 July 2010 12:32, Martin Moore <martin.moore at avbrief.com> wrote:
> Greeting pop-pickers.
>
> Well, I took the plunge and started the upgrade to Lenny on a fully 
> functioning but 'unused' server.
>
> Using
> http://www.debian.org/releases/lenny/i386/release-notes/ch-upgrading.h
> tml
>
> Things went well (apart from removing just about all of our inhouse 
> packages, but I can live with that :) ) until the kernel.
> Did
>
> aptitude safe-upgrade
> aptitude dist-upgrade
>
> (I think perl may have played up here too, but I thought I'd sort it 
> out
> later!)
>
> first.
>
>
> This ain't my area of expertise, anyone care to proffer some sage advice?
>
>
> Ta.
>
> $ aptitude install linux-image-2.6-686
>
> Install the following packages:
> libcompress-raw-zlib-perl [2.012-1lenny1 (stable)] libdbd-sqlite3-perl
> [1.14-3 (stable)] libio-compress-base-perl [2.012-1 (stable)] 
> libio-compress-zlib-perl [2.012-1 (stable)]
>
> Upgrade the following packages:
> libberkeleydb-perl [0.31-1 (now) -> 0.34-1+b1 (stable)] 
> libclass-dbi-sqlite-perl [0.11-2 (now) -> 0.11-3 (stable)] 
> libclone-perl [0.23-1 (now) -> 0.29-1 (stable)] libcompress-zlib-perl
> [1.42-2 (now) -> 2.012-1 (stable)] libcrypt-ssleay-perl [0.51-5 (now)
> -> 0.57-1+b1 (stable)] libdate-calc-perl [5.4-5 (now) -> 5.4-5+b1
> (stable)] libdate-simple-perl [3.02-1 (now) -> 3.03.03-1+b1 (stable)] 
> libdbd-pg-perl [1.49-2+etch1 (now) -> 2.8.7-1+lenny1 (stable)] 
> libdbi-perl [1.53-1etch1 (now) -> 1.605-1 (stable)] 
> libdigest-sha1-perl [2.11-1 (now) -> 2.11-2+b1 (stable)] libfcgi-perl
> [0.67-2 (now) -> 0.67-2.1+b1 (stable)] libfile-mmagic-xs-perl [0.09-1
> (now) -> 0.09003-1+b1 (stable)] libhtml-parser-perl [3.56-1 (now) ->
> 3.56-1+lenny1 (stable)] libio-pty-perl [1:1.05-2 (now) -> 1:1.07-1+b1 
> (stable)] libipc-sharelite-perl [0.09-3 (now) -> 0.13-1+b1 (stable)] 
> liblocale-gettext-perl [1.05-1 (now) -> 1.05-4 (stable)] 
> libnet-dns-perl [0.59-1etch1 (now) -> 0.63-2 (stable)] 
> libnet-ssleay-perl [1.30-1 (now) -> 1.35-1 (stable)] 
> libparams-validate-perl [0.88-1 (now) -> 0.91-2 (stable)] libpg-perl
> [1:2.1.1-3 (now) -> 1:2.1.1-4 (stable)] librrds-perl [1.2.15-0.3 (now)
> -> 1.3.1-4 (stable)] libsocket6-perl [0.19-1 (now) -> 0.20-1 (stable)]
> libsub-name-perl [0.02-1 (now) -> 0.04-1 (stable)] 
> libterm-readkey-perl [2.30-3 (now) -> 2.30-4 (stable)] 
> libtext-charwidth-perl [0.04-4 (now) -> 0.04-5+b1 (stable)] 
> libtext-iconv-perl [1.4-3 (now) -> 1.7-1+b1 (stable)] 
> libunix-syslog-perl [0.100-5 (now) -> 1.1-2 (stable)] libwant-perl
> [0.09-1 (now) -> 0.18-1+b1 (stable)] libxml-libxml-common-perl [0.13-5
> (now) -> 0.13-6+b1 (stable)] libxml-libxml-perl [1.59-2 (now) ->
> 1.66-1+b1 (stable)] libxml-parser-perl [2.34-4.2 (now) -> 2.36-1.1+b1 
> (stable)] libxml-sablot-perl [1.0-2 (now) -> 1.0-2+b1 (stable)] perl
> [5.8.8-7etch6 (now) -> 5.10.0-19lenny2 (stable)] perl-base
> [5.8.8-7etch6 (now) -> 5.10.0-19lenny2 (stable)] perlmagick
> [7:6.2.4.5.dfsg1-0.15+etch1 (now) -> 7:6.3.7.9.dfsg2-1~lenny3 
> (stable)] ..
> ..
> ..
> ..
> Extracting templates from packages: 100% Can't locate File/Find.pm in 
> @INC (@INC contains: /usr/share/perl5/
> /usr/share/perl/5.8.4 /etc/perl /usr/local/lib/perl/5.8.8
> /usr/local/share/perl/5.8.8 /usr/lib/perl5 /usr/share/perl5
> /usr/lib/perl/5.8 /usr/share/perl/5.8 /usr/local/lib/site_perl
> /usr/local/lib/perl/5.8.4 /usr/local/share/perl/5.8.4 .) at 
> /usr/bin/debsums line 10.
> BEGIN failed--compilation aborted at /usr/bin/debsums line 10.
> E: Problem executing scripts DPkg::Post-Invoke 'if [ -x 
> /usr/bin/debsums ]; then /usr/bin/debsums --generate=nocheck -sp
/var/cache/apt/archives; fi'
> E: Sub-process returned an error code
> E: Sub-process /usr/bin/dpkg returned an error code (1) A package 
> failed to install.  Trying to recover:
> dpkg: dependency problems prevent configuration of perl-modules:
>  perl-modules depends on perl (>= 5.10.0-1); however:
>  Version of perl on system is 5.8.8-7etch6.
> dpkg: error processing perl-modules (--configure):
>  dependency problems - leaving unconfigured
> dpkg: dependency problems prevent configuration of libbit-vector-perl:
>  libbit-vector-perl depends on perl (>= 5.10.0-9); however:
>  Version of perl on system is 5.8.8-7etch6.
>  libbit-vector-perl depends on perlapi-5.10.0; however:
>  Package perlapi-5.10.0 is not installed.
> dpkg: error processing libbit-vector-perl (--configure):
>  dependency problems - leaving unconfigured
> dpkg: dependency problems prevent configuration of libconvert-uulib-perl:
>  libconvert-uulib-perl depends on perl (>= 5.10.0-11); however:
>  Version of perl on system is 5.8.8-7etch6.
>  libconvert-uulib-perl depends on perlapi-5.10.0; however:
>  Package perlapi-5.10.0 is not installed.
> dpkg: error processing libconvert-uulib-perl (--configure):
>  dependency problems - leaving unconfigured
> dpkg: dependency problems prevent configuration of libdatetime-perl:
>  libdatetime-perl depends on perlapi-5.10.0; however:
>  Package perlapi-5.10.0 is not installed.
> dpkg: error processing libdatetime-perl (--configure):
>  dependency problems - leaving unconfigured Errors were encountered 
> while processing:
>  perl-modules
>  libbit-vector-perl
>  libconvert-uulib-perl
>  libdatetime-perl
>  libcurses-ui-perl{a} libdbd-sqlite-perl{a} libdevel-symdump-perl{u}
>  libdigest-nilsimsa-perl{a} libfsplib0{u} liblinux-inotify2-perl{a}
>  libmath-geometry-planar-gpc-perl{u}
>  libmath-geometry-planar-offset-perl{u}
> libmath-geometry-planar-perl{u}
>  libmaypole-perl{a} libmd5-perl{u} libpdl-netcdf-perl{u} libplplot9{u}
>  libproj-perl{u} libqhull5{u} libsgi-fam-perl{a} libtemplate-perl{a}
>  libtemplate-plugin-class-perl{a} libterm-readkey-perl{u} pdl{a}
>  sysv-rc-conf{a}
> The following packages will be upgraded:
>  libberkeleydb-perl libclass-dbi-sqlite-perl libclone-perl
>  libcompress-zlib-perl libcrypt-ssleay-perl libdate-calc-perl
>  libdate-simple-perl libdbd-pg-perl libdbi-perl libdigest-sha1-perl
>  libfcgi-perl libfile-mmagic-xs-perl libhtml-parser-perl 
> libio-pty-perl
>  libipc-sharelite-perl liblocale-gettext-perl libnet-dns-perl
>  libnet-ssleay-perl libparams-validate-perl libpg-perl librrds-perl
>  libsocket6-perl libsub-name-perl libtext-charwidth-perl
>  libtext-iconv-perl libunix-syslog-perl libwant-perl
>  libxml-libxml-common-perl libxml-libxml-perl libxml-parser-perl
>  libxml-sablot-perl perl perl-base perlmagick The following partially 
> installed packages will be configured:
>  libbit-vector-perl libconvert-uulib-perl libdatetime-perl 
> perl-modules
> 34 packages upgraded, 4 newly installed, 39 to remove and 19 not upgraded.
> Need to get 0B/9431kB of archives. After unpacking 28.9MB will be freed.
> Do you want to continue? [Y/n/?] Writing extended state information...
> (Reading database ... 62580 files and directories currently
> installed.) Preparing to replace perl 5.8.8-7etch6 (using
> .../perl_5.10.0-19lenny2_i386.deb) ...
> Unpacking replacement perl ...
> dpkg: error processing
> /var/cache/apt/archives/perl_5.10.0-19lenny2_i386.deb
> (--unpack):
>  trying to overwrite `/usr/bin/config_data', which is also in package 
> libclass-dbi-dfv-perl
> dpkg-deb: subprocess paste killed by signal (Broken pipe) Processing 
> triggers for man-db ...
> Errors were encountered while processing:
>  /var/cache/apt/archives/perl_5.10.0-19lenny2_i386.deb
> Reading package lists...
> Building dependency tree...
> Reading state information...
> Reading extended state information...
> Initializing package states...
> Writing extended state information...
>
>
>
> --
> underscore_ list info/archive ->
> http://www.under-score.org.uk/mailman/listinfo/underscore
>



--
Andrew McGregor
+44 7940 22 33 11

-- 
underscore_ list info/archive ->
http://www.under-score.org.uk/mailman/listinfo/underscore
No virus found in this incoming message.
Checked by AVG - www.avg.com 
Version: 9.0.830 / Virus Database: 271.1.1/2985 - Release Date: 07/09/10
07:36:00


-- 
underscore_ list info/archive ->
http://www.under-score.org.uk/mailman/listinfo/underscore
No virus found in this incoming message.
Checked by AVG - www.avg.com 
Version: 9.0.830 / Virus Database: 271.1.1/2985 - Release Date: 07/09/10
07:36:00